1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pthreads not working on Netbeans using Cygwin

Discussion in 'C' started by blackrobe, Sep 30, 2010.

  1. blackrobe

    blackrobe New Member

    Sep 30, 2010
    Likes Received:
    Trophy Points:
    Hey there,

    I'm currently using NetBeans 6.8 running Cygwin GNU Bash version 3.2.49(23)-release.

    I'm having a problem running my program that uses pthreads, mutexes, and semaphores. After it creates 1 to 3-4 threads, it returns a Segmentation fault.

    I ran the program on a computer running Linux (using NetBeans as well) and had no issues running (i.e. didn't return Segmentation fault).

    Is there a fix for this problem?

    I also tried debugging in NetBeans but after the program starts creating threads, I try to select threads from the "Threads" tab in the debugging menu, but would not let me step into one thread at a time, and then gives me a Segmentation Fault error message. So I was also wondering if there was a solid way to debug multi-threads on NetBeans.

    Thank you for your help.

Share This Page