Java error when on front end when connecting to database

Discussion in 'PostgreSQL' started by CRICHEY220, Sep 30, 2011.

  1. CRICHEY220

    CRICHEY220 New Member

    Sep 30, 2011
    Likes Received:
    Trophy Points:

    Receiving this error when trying to hit third-party EMR application via HTTP; platform is Debian GNU/Linux, PostgreSQL is version 8.3, but have a previous instance of 8.2 on the machine that's not currently running. It has worked in the past for quite sometime, but I had to bounce the box and hop into single-user mode to reset root password, as we forgot it. As soon as I did that, and brought the server back up, this is the error we are all getting now.

    What I've done to troubleshoot:

    -Ensured that postgresql-8.3 and apache2 daemons were running via sysvconfig
    -Ran this command under "postgres" user - "pg_ctl start -D /etc/postgresql/8.3/main -l postgres2011.log" (just created a new random log file, not sure if that was correct)
    -Found what I believe are .jar files for current application, and tried to start "java -jar /absolute path of jar file" but received an error "Failed to load Main-Class manifest attribute"

    I'm not even sure if I headed down the right path to begin with (I took this client over just a few weeks ago). This is simply a custom web app that has been written, and uses a PostgreSQL DB for the back end. Not too sure where to go from here, any help at all would be much appreciated, thank you much in advance.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice