1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error in page33!!

Discussion in 'PHP' started by idz, Sep 8, 2007.

  1. idz

    idz New Member

    Joined:
    Sep 1, 2007
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    Code:
    <HTML>
    <HEAD>
    <TITLE>MY FIRST PHP PROGRAM</TITLE>
    </HEAD>
    <BODY>
    <?PHP
    ECHO "I'M A LUMBERJACK.";
    ?>
    </BODY>
    </HTML>
    The above program when run in my Firefox browser shows no output.Only a title "My First PHP Program" is appearing in the title bar.
    The source code is listed in page33 of the Book called - "Beginning PHP5,Apache,MySQL Web Development" by E. Naramore,J. Gerner,Stolz,M.Glass,Yann Le(Wrox Publication).
    I have WAMP5(latest) installed.
    What to do to see the output?
    Are there errors in the code above? :eek:
     
    Last edited by a moderator: Sep 8, 2007
  2. shabbir

    shabbir Administrator Staff Member

    Joined:
    Jul 12, 2004
    Messages:
    15,309
    Likes Received:
    369
    Trophy Points:
    83
    Code:
    <HTML>
      <HEAD>
        <TITLE>MY FIRST PHP PROGRAM</TITLE>
      </HEAD>
      <BODY> 
        <?PHP echo "Hello to the world of PHP"; ?>
      </BODY>
    </HTML>
    What is the output for the following program.
     
  3. jwshepherd

    jwshepherd New Member

    Joined:
    Aug 13, 2007
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    VP Technology Corporation
    Location:
    Texas
    Home Page:
    Disabling IIS and setting Apache to auto start will help. Make sure your php.ini file is copied to your windows system32 folder as well.
     
  4. idz

    idz New Member

    Joined:
    Sep 1, 2007
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    Hii, :)
    Thanks everyone for the replies.
    Thanks Shabbir.It worked. :D
    How to disable IIS & set Apache to autostart everytime Windows starts?At present,I cant start Apache server without disabling IIS every time windows boots up. :rolleyes:
    Also,I have installed wamp5 in C:\wamp\.
    Then where to find the php.ini file?
    And,also how to avoid manually typing the path http://localhost/ 'programename'.php in my browsereverytime I have to execute a program in browser?
    Is there a way to run it in my browser just by RClicking on the "program name" in the test folder( I have created a "test" folderunder c:\wamp\test)?
     
  5. idz

    idz New Member

    Joined:
    Sep 1, 2007
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    Also, in my PHP Folder I have many php files with various extensions but none exactly with the .ini extension.There is one php configuration settings notepad file,a php Application (CLI) file,
    php Application (CGI/Fast CGI) file,php-win(CLI) file,php.ini-dist,php.ini-recommended file and 2 registry files - pws-php5cgi,pws-php5isapi.
    ...So many files with the name 'php' are there...which one to copy?? :confused:
     
  6. jwshepherd

    jwshepherd New Member

    Joined:
    Aug 13, 2007
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    VP Technology Corporation
    Location:
    Texas
    Home Page:
    to avoid typing programname change the page name to index.php.
    the "There is one php configuration settings notepad" is the ini file, but if the above worked leave it alone
     

Share This Page