1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Compile Error in Perl

Discussion in 'Perl' started by liveproject101, Apr 12, 2013.

  1. liveproject101

    liveproject101 New Member

    Apr 9, 2013
    Likes Received:
    Trophy Points:
    PRE.cjk { font-family: "WenQuanYi Zen Hei Sharp",monospace; }P { margin-bottom: 0.08in; }CODE.cjk { font-family: "WenQuanYi Zen Hei Sharp",monospace; }A:link { } I tried to compile my program but I get the following error
    g++ fn-test.cpp -o t 'perl -MExtUtils::Embed -e ccopts -e ldopts' g++: perl -MExtUtils::Embed -e ccopts -e ldopts: No such file or directory fn-test.cpp:2:24: fatal error: EXTERN.h: No such file or directory compilation terminated. I am working on ubuntu so I went into cpan and ran
    force install ExtUtils::Embed it did it's thing for a while and now when I try to compile again, I get the same error. This is my first time trying to call a Perl program from C++, so any tips would be helpful.

Share This Page