1. We have moved from vBulletin to XenForo and you are viewing the site in the middle of the move. Though the functional aspect of everything is working fine, we are still working on other changes including the new design on Xenforo.
    Dismiss Notice

[READ THIS] i need help; please!!!!!

Discussion in 'C' started by m_t_h, Jul 2, 2010.

  1. m_t_h

    m_t_h New Member

    hi everybody can anywho tell me what i did wrong:

    ook my problem. you see when you create new project bla bla bla and then you have some sheet in header files and source files. i deleted all and created new there was somethink called: stdafx.h . i delted that too now, when i want to debug i get 1 error. called: did you forget to add "#inc... "STDAFX.h" to your source! but i delted that! wtf?

    How to fix that? somebody told me that:
    check your precompiled settings

    but where to do that?????
    THANKS!!! I REALLY need your help!:cryin:
     
  2. m_t_h

    m_t_h New Member

    ow yea, srry for duble post, i was creating .dll
     
  3. xpi0t0s

    xpi0t0s Mentor

    Visual Studio uses something called precompiled headers. It speeds up compiling time. To use it you have to (a) ensure using precompiled headers is switched on and (b) include stdafx.h. If you don't want to use precompiled headers then (a) switch precompiled headers off *AND* (b) delete the #include.

    To switch precompiled headers off go to the Project menu, select Properties, in the left pane expand Configuration Properties then C/C++, then select Precompiled Headers. In the right pane change Create/Use Precompiled Headers to Not Using Precompiled Headers.

    But by the sounds of it you don't know enough to know that you don't need it. Leave it on and stop deleting the include stdafx.h.
     

Share This Page