I've been playing with the notion of making my own game engine and these are some starter functions I wrote for in game stats. percentage Code: double percent(double n,double d) { return n / d * 100; } ratio Code: double ratio(double n,double d) { return n / d; }
It's a bit pointless having a function that just takes one line of code. Better just to use those single lines of code instead of calling the function; it looks here as if you're trying to rewrite C in some other language, which doesn't work. A function should do something useful, not just redefine an operator. Also the parameter names should be descriptive. n and d mean nothing. Do you mean numerator and denominator?
Its easier to just supply the arguments to the function. This belongs to a class for all my stats. I don't see how I'm rewriting the language if I'm using standard C++. You have the name for n and d correct as the params though.
i think there's actually a objective in what pein87 is doing as he said that he is using those functions in game there are several uses 1: can prevent the repeat of the code though it is single line, this makes the code more readeable 2: he can add what ever additions to the function body to change the output which is VERY much easier in contrast with replacing all the lines