Go4Expert

Go4Expert (http://www.go4expert.com/)
-   C (http://www.go4expert.com/forums/c/)
-   -   question on browser to server connection (http://www.go4expert.com/forums/question-browser-server-connection-t27796/)

tommytopple 15Feb2012 08:45

question on browser to server connection
 
Hello people. I am trying to develope a html link that when i click on ym web site will contact my c+ server. In this link i wish to tack on the end a variable like how people do it in php with a ? after the address and before the variable.


I know so far that if my server is running and i type local host into my web browser that it will make a connetion with my server. So the concept is working right. This will only work with my loopback address 127.0.0.1 and local host which are the same thing. If i try to use my ip address for this, it will not work. this is veyr annoying and i dont understand why if my loopback address works why wont my ip. I need to be able to use my ip to finish this concept to fully work.

Ive come to a few conclusions. Either it is a port forwarding problem or i need to use a domain name to do that. I want to do all of this without having to upload a web site, and all. I hear it is possable to type your ip address into a browser and connect with your home server. please help thank you and good bye.

xpi0t0s 16Feb2012 18:25

Re: question on browser to server connection
 
Are you using an external IP address or an internal one? If you're trying to use the one assigned you by your ISP there's a good chance this is the cause of the problem. Instead use the one assigned you by your router. So for example if I type "ipconfig" in a DOS box I see my router has assigned me the IP address 192.168.1.69. So http://127.0.0.1 and http://192.168.1.69 should both have the same effect.


All times are GMT +5.5. The time now is 06:07.