Go4Expert

Go4Expert (http://www.go4expert.com/)
-   C# (http://www.go4expert.com/forums/c-sharp/)
-   -   Problem in installing .Net Framework 3.5 (http://www.go4expert.com/forums/installing-net-framework-35-t20658/)

Carlos 13Jan2010 19:46

Problem in installing .Net Framework 3.5
 
Hi! everyone, i have recently installed windows xp with service pack 3 and have installed windows installer 4 , but now i try to install .Net Framework 3.5 it generates an error:

An error encountered during setup. Installed files have been removed from the computer. For known issues and troubleshooting information, see online Readme. For error information, see Error Log.

Please see my error log:
Code:

[01/13/10,06:43:27] Microsoft .NET Framework 2.0a: [2] Failed to fetch setup file in CBaseComponent::PreInstall()
[01/13/10,06:43:27] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
[01/13/10,06:43:27] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
[01/13/10,06:43:27] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
[01/13/10,06:43:27] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
[01/13/10,06:43:27] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
[01/13/10,06:43:28] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
[01/13/10,06:43:28] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
[01/13/10,06:43:28] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.
[01/13/10,06:43:28] WapUI: [2] DepCheck indicates XPSEPSC Installer was not attempted to be installed.
[01/13/10,06:43:28] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a was not attempted to be installed.
[01/13/10,06:43:28] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.
[01/13/10,09:51:10] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
[01/13/10,09:51:21] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.
[01/13/10,14:05:15] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] Failed to fetch setup file in CBaseComponent::PreInstall()
[01/13/10,14:05:15] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
[01/13/10,14:05:15] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
[01/13/10,14:05:15] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
[01/13/10,14:05:15] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
[01/13/10,14:05:15] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
[01/13/10,14:05:15] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
[01/13/10,14:05:15] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
[01/13/10,14:05:16] WapUI: [2] DepCheck indicates Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86) is not installed.
[01/13/10,14:05:16] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a was not attempted to be installed.
[01/13/10,14:05:16] WapUI: [2] DepCheck indicates XPSEPSC Installer was not attempted to be installed.
[01/13/10,14:05:16] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 was not attempted to be installed.
[01/13/10,14:05:16] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.
[01/13/10,14:14:41] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
[01/13/10,14:14:54] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.
[01/13/10,14:21:58] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
[01/13/10,14:22:10] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

Now i cannot even installed framework 2.0 because of half installation of 3.5.


All times are GMT +5.5. The time now is 23:52.