Go4Expert

Go4Expert (http://www.go4expert.com/)
-   Linux (http://www.go4expert.com/forums/linux-forum/)
-   -   Issue in removing the modules in linux (http://www.go4expert.com/forums/issue-removing-modules-linux-t20007/)

gk123987 6Nov2009 12:10

Issue in removing the modules in linux
 
I am using the Mandriva Linux - 2008 version.
Recently I have compiled the latest kernel source - 2.6.xx.5

I tried to compile a single module and tried inserting and removing using the commands - insmod and rmmod, they were successful.

But now i added another module file and tried to build the module. The build was successful.

Using the Insmod, i inserted both in to kernel space.
When i tried to removed the module, i get the error saying,

"Module is in use and can not be removed".

Is there any means - to kill this module.

gk123987 6Nov2009 12:20

Re: Issue in removing the modules in linux
 
ps - will give the running pid and then i can kill it.
But on exiting of the module, i have some msgs to be printed and this is not happening.That is on inserting - i have some msg to be printed and on removing i print some message.

Can any one pls smell the issue i am facing.

Thanks and Regards,
GK


All times are GMT +5.5. The time now is 15:51.