Go4Expert

Go4Expert (http://www.go4expert.com/)
-   C# (http://www.go4expert.com/forums/c-sharp/)
-   -   .Net Framework 3.5 installation error (http://www.go4expert.com/forums/net-framework-35-installation-error-t19789/)

Carlos 17Oct2009 13:06

.Net Framework 3.5 installation error
 
Hi! I wanna install .Net Framework 3.5, but it generate an error in the initial stage of installation. please view its log file

Code:

[10/11/09,20:24:09] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] Failed to fetch setup file in CBaseComponent::PreInstall()
[10/11/09,20:24:09] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
[10/11/09,20:24:09] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
[10/11/09,20:24:09] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
[10/11/09,20:24:09] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
[10/11/09,20:24:09] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
[10/11/09,20:24:09] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
[10/11/09,20:24:09] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
[10/11/09,21:32:15] Microsoft .NET Framework 2.0a: [2] Failed to fetch setup file in CBaseComponent::PreInstall()
[10/11/09,21:32:15] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
[10/11/09,21:32:15] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
[10/11/09,21:32:15] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
[10/11/09,21:32:15] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
[10/11/09,21:32:15] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
[10/11/09,21:32:15] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
[10/11/09,21:32:16] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
[10/11/09,23:12:08] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
[10/11/09,23:12:25] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.
[10/16/09,21:14:35] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
[10/17/09,00:02:57] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
[10/17/09,00:03:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.
[10/17/09,00:56:46] Microsoft .NET Framework 3.0a: [2] Error: Installation failed for component Microsoft .NET Framework 3.0a. MSI returned error code 1603
[10/17/09,00:57:00] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a is not installed.

i have installed windows installer 4.5 and have XP with service pack 3.
Please someone help me out of this problem


All times are GMT +5.5. The time now is 01:58.