Go4Expert

Go4Expert (http://www.go4expert.com/)
-   MySQL (http://www.go4expert.com/forums/mysql-forum/)
-   -   Authentication errror on Solaris 10 for MySQl 5.1 version. (http://www.go4expert.com/forums/authentication-errror-solaris-10-mysql-t19329/)

amit_27 7Sep2009 13:13

Authentication errror on Solaris 10 for MySQl 5.1 version.
 
Hi,

I have build one application which uses static reference of MySQL 4.0 old version library and dynamic reference of new version as MySQL 5.1 version library.
On Solaris
When I try to connect to MySQL server 5.1 using MySQL 5.1 library in application it always uses the old version library instead 5.1 library and I get the following error:

DataAccess: MySQL error: Client does not support authentication protocol requested by server; consider upgrading MySQL client; errno = 1251

On solaris 10 mahcine I have only installed MySQL 5.1. When I try to connect to MySQL server using mysql prompt it connects properly.

Also I have written one sample application which only uses the MySQL 5.1 library dynamic reference and trying to connect to Server 5.1. it connects successfully.

I wonder why in my Application it uses the old even I given or linked the new 5.1 version library.

Is there any compile time linking problem on Solaris or run time problem which does not allows like this mechanism or other else need to do to solve it?

Any help on this highly appreciated?


All times are GMT +5.5. The time now is 23:45.