Go4Expert

Go4Expert (http://www.go4expert.com/)
-   Linux (http://www.go4expert.com/forums/linux-forum/)
-   -   Problem multibooting fedora 6, rh9, xp (http://www.go4expert.com/forums/multibooting-fedora-6-rh9-xp-t13165/)

e-sam 23Aug2008 03:48

Problem multibooting fedora 6, rh9, xp
 
hi all
need your help, i'm abit stuck

i installed windows in hda1 then fedora core 6 on another partition (hda2), and red hat 9 on hda5 [according to grub's hard disk notation]. i also created 2 swap spaces for both linux versions. Also, i did not create boot partitions on both linux os's. I can boot into windows and red hat, but when i try into boot into fedora i get this error
(this might be important: i'm using grub for red hat)

rootnoverfy (hd0,1)
chainloader +1

"Error 13: Invalid or unsupported executable format"
Press any key to continue...

And here is my partitioning table:

Disk /dev/hda:


Device Boot Start End Blocks Id System

/dev/hda1 1 4199 31744408+ 7 HPFS/NTFS

/dev/hda2 * 4200 7423 24370605 83 Linux

/dev/hda3 7423 7562 1052257+ 82 Linux swap

/dev/hda4 7563 10587 22869000 f Win95 Ext'd (LBA)

/dev/hda5 7702 10587 21818160 83 Linux

/dev/hda6 7563 7701 1050777 82 Linux swap


Partition table entries are not in disk order

and here is my grub.conf file


# grub.conf generated by anaconda

#

# Note that you do not have to rerun grub after making changes to this file

# NOTICE: You do not have a /boot partition. This means that

# all kernel and initrd paths are relative to /, eg.

# root (hd0,4)

# kernel /boot/vmlinuz-version ro root=/dev/hda5

# initrd /boot/initrd-version.img
#boot=/dev/hda

default=1

timeout=10

splashimage=(hd0,4)/boot/grub/splash.xpm.gz

title Red Hat Linux (2.4.20-8)

root (hd0,4)

kernel /boot/vmlinuz-2.4.20-8 ro root=LABEL=/1

initrd /boot/initrd-2.4.20-8.img
title Windows XP Professional

rootnoverify (hd0,0)

chainloader +1
title Fedora Core 6

rootnoverify (hd0,1)

chainloader +1


your help is welcome..

neo_vi 24Oct2008 16:04

Re: Problem multibooting fedora 6, rh9, xp
 
fedora is not in that location(hd0,1). Check that. attach ur menu.lst file


All times are GMT +5.5. The time now is 00:45.