Try Login to your wp-admin and see if it works. If not you have to edit the wp-options table to change the blog url