Just right click on your project, go to settings/properties ....see linker setting....see the linked libraries....if mfc42d.lib is there in libraries to link to. remove it from there.....just look for mfc42d.lib in you project setting, i do not have vc 6 now else i would have told you the exact.....
I think this might be the solution....