These are stuff are teacher is telling us not to do. For instance our teacher is telling us to always use:

Code:
return 0;
and our teacher told us to make it well documented with as few comments as possible and not to document every line.
as far as the following
Code:
if (0.0 > price)

But if you're going to insist on doing it, then be consistent:
} while(price < 0.0);
I asked the teacher if the following would work

Code:
if (price > 0.0)

} while (price < 0.0)
as I always like to put the variable first in arguments, however the teacher sent me a message back say it should be the way it is now as it looks better.

I appreciate your comments and sorry about the allot instead of a lot. I am not the best at grammar.