You don't need the express edition but you need the DotNet Framework to run any dot net application.