yes i did... which version do u suggest i use?