venami's Avatar, Join Date: Dec 2008
Ambitious contributor
Solution 2:
Usually Skype uses the port number 80 that apache/any other webserver uses. So if have installed Skype, change its configuration to use some other port or stop it when you need to run apache.

Solution 3:
Find the service/application that uses the port 80 and stop it, and then start apache. You don't need to touch the configuration files to change the port number usage.
shyam_oec's Avatar, Join Date: Nov 2007
Contributor
ALL IN THE VAIN.
As instructed i changed the port number from 80 to 8083.still problem,but at this time error message is showing that no listing port available at port number at address:0.0.0.0:443
Amazingly i gave port number 8083 in httpd.conf file ,but it is trying to open port number 443..
What's going on sir!
shyam_oec's Avatar, Join Date: Nov 2007
Contributor
I don't have Skype.
venami's Avatar, Join Date: Dec 2008
Ambitious contributor
You have enabled secure connection for your webpages(SSL) which uses the port 443

The same is coming again, but for a different port.

Solution1:
Find the other service which uses this port 443 and disable it. I guess your Apache Tomcat is using this one.

Solution 2:
Comment out the line in apache configuration file which says to use 443 port(do this if don't want secure connection for now) or else change that port number to some other port.
venami's Avatar, Join Date: Dec 2008
Ambitious contributor
Hi shyam,

Have you resolved the problem? Or still facing the same issue?
shyam_oec's Avatar, Join Date: Nov 2007
Contributor
Hi,
It is giving same problem.In The apache configuration file httpd.conf when port numbe is set to 80 it is trying to open at port 80,but unable to start at port 80.It is showing in the message.
But when i set the port number to something else like 81 or 8083 it is automatically trying to open at port 443,which again is unsuccessful.
I have already uninstalled my earlier software Apache Tomcat Server.Then how i can know which software is using port number 443?
And why xampp apache is by default trying t open at port 443?
venami's Avatar, Join Date: Dec 2008
Ambitious contributor
Usually for secure connections(SSL), port 443 is used. Since port 80 problem was solved, the webserver found the next problem in line which is for 443. That is the reason why you get this error.

To know the applications that are using a specific port, try the following command in cmd:
netstat -a

Find out the applications that use port 80 and 443 and stop them, or else post the result of the above command.
venami's Avatar, Join Date: Dec 2008
Ambitious contributor
To find the executables that created the process, use the -b option:
netstat -b
neo_vi's Avatar, Join Date: Feb 2008
Invasive contributor
I think the localhost's IP is not set correctly. can u post the contents of the file 'C:\windows\system32\drivers\etc\hosts' (assuming C:\ is the drive where u installed windows) here, so that I can help u out.
shyam_oec's Avatar, Join Date: Nov 2007
Contributor
hi,
when typing netstat -b or netstat -a different process that are running are shown with specific port number,but there are no any programs shown that is using port number 443.
I think main problem is due to oracle that is installed in my computer.
Because when i tried the same software in another system that is not using oracle xampp is running well.