Ok,I have done it.Its working now.Thanks. Now Ihave re-installed the apache server and PHP with support to default extensions.Before I was selecting all the extensions availaBLEINTHE PACKAGE THATS WAHY IT WAS GIVING ERROR,as there were no dependencies available with the package foreach extension..