Try this:

replace @ with colon
Quote:
http://msdn.microsoft.com/en-us/libr...mmandtext.aspx
When using named parameters in an SQL statement called by an OracleCommand of CommandType.Text, you must precede the parameter name with a colon ( : ). However, in a stored procedure, or when referring to a named parameter elsewhere in your code (for example, when adding OracleParameter objects to the Parameters property), do not precede the named parameter with a colon ( : ). The .NET Framework Data Provider for Oracle supplies the colon automatically.
OR modifying to this:
Quote:
http://msdn.microsoft.com/en-us/libr...parameter.aspx
oracmd.Parameters.Add("@name", OleDbType.Char, 3).Value = TextBox1.Text.ToString();
OR try inserting the value in string directly, instead of giving by parameter.
String orains = "insert into T6 values('" & TextBox1.Text.ToString() & "')";

Last edited by nimesh; 2Nov2009 at 00:34..
shyam_oec like this