This stuff is really confusing. Unless you absolutely cannot avoid it, leave it until you're more experienced. The behaviour is platform-dependent, so at the very least you have to tell us *exactly* what OS you're using, including the full version number, 32- or 64-bit, any patches installed, and what compiler you're using, again including the full version number, 32- or 64-bit.
lionaneesh like this