i cant post the code anywhere as its against our company policy(security)....while writing the code i took special care to use POSIX APIs which are availabe to linux 2.4 and above and also to turbo...
i thought tht should be enough to take care about the compatibility issues and make it work on diff OS..

anyways, seems like its the end of the road...if any1 has any ideas please post here..

thanx once again