yeah i actually figured this one out a while ago and never really got around to posting the solution. well as you said i went into the bios and changed sata from disabled to compatibility. and that fixed it. kinda a dumb thing... and i stumbled upon the fix by complete fluke.