You would need the latest version of the service pack to work on it in Vista