1. We have moved from vBulletin to XenForo and you are viewing the site in the middle of the move. Though the functional aspect of everything is working fine, we are still working on other changes including the new design on Xenforo.
    Dismiss Notice

need some help installing madwifi

Discussion in 'Linux' started by cpulocksmith, Mar 1, 2009.

  1. cpulocksmith

    cpulocksmith New Member

    Joined:
    Jul 23, 2008
    Messages:
    289
    Likes Received:
    5
    Trophy Points:
    0
    Occupation:
    student
    Location:
    canada
    ok well it all started when i was trying to install kismet... well instally, instally, error! it told me i need to configure the capture source, mmmmm. well turns out i need madwifi. ok. so i went to find it. and success. i found it. so madwifi, and i read the INSTALL file and it tells me to type make. ok that kinda normal. so i do it. and it starts to make...making...making...making...
    /home/locksmith/tools/madwifi-0.9.4/net80211/ieee80211_power.c: In function 'ieee80211_pwrsave':
    /home/locksmith/tools/madwifi-0.9.4/net80211/ieee80211_power.c:240: error: implicit declaration of function '__skb_append'
    make[3]: *** [/home/locksmith/tools/madwifi-0.9.4/net80211/ieee80211_power.o] Error 1
    make[2]: *** [/home/locksmith/tools/madwifi-0.9.4/net80211] Error 2
    make[1]: *** [_module_/home/locksmith/tools/madwifi-0.9.4] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.27.15-170.2.24.fc10.i686'
    make: *** [modules] Error 2


    ....what?!
    i really have no clue what to do... please some one tell me... i have been searching and searching and everything i try fails. i am running fedora 10.
     

Share This Page