It prompts me for the date now, and it comes back with that error once I specify a date range.

Any ideas?