1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CGI Error - CGI application misbehaved by not returning a complete set of HTTP Header

Discussion in 'Perl' started by HMM, Nov 15, 2007.

  1. HMM

    HMM New Member

    Joined:
    Nov 15, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Guys, I am getting following error,

    CGI Error
    The specified CGI application misbehaved by not returning a complete set of HTTP headers.

    Here is a program,
    Code:
    use CGI qw/:all/;
    use MIME::Base64;
    
    $web = new CGI;
    $FirstScreenIn = 1;
    require "d:/inetpub/APP/cgi/cookie/GetCookie.pl";
    &GetCookie;
    
    if ($UsernameIn eq "") {
       print $web->header();
       print "REDIREDCT*****".$UsernameIn;
    
    } else {
    ...
    }
    
    GetCookie.pl
    Code:
    sub GetCookie {
    #!perl -w
    use CGI qw/:standard/;
    use CGI::Cookie;
    use MIME::Base64;
    %Cookies = fetch CGI::Cookie;
    ...
    use SOAP::Lite; 
    I use activePerl and is hosted by IIS 5.0

    Can anyone give my direction to look for the issue? TIA
     
    Last edited by a moderator: Nov 16, 2007
  2. pradeep

    pradeep Team Leader

    Joined:
    Apr 4, 2005
    Messages:
    1,646
    Likes Received:
    86
    Trophy Points:
    0
    Occupation:
    Programmer
    Location:
    Kolkata, India
    Home Page:
    The required file GetCookie.pl should return a true value!
     

Share This Page