You need to enable the display signature options from your control panel to see the signature.

1. Go to My Go4Expert
2. Go to Edit options
3. Check on the Check box Show Signatures

Its by default off for any new user who registers on the forum.

It has been added to the FAQ section as well.